Ram Promaster Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hey guys, so I mentioned in my introduction post that I started having issues with my '14 diesel Promaster with 6k miles. I bought it roughly 2 weeks ago, and started having problems after putting 300-400miles on it. Here's the issue, and what I have been told along the way by 3 different dealerships.

So 4 days after I bought the PM I was driving home from work, and I was going roughly 45mph, slowed down to make a turn, turned and when I went to accelerate back up to speed I lost all response from the gas pedal, and the transmission put itself in Neutral, although the stick was still in Drive. I coasted into a gas station, turned it off and let it sit for a few moments. A few mins went by and it fired right now like nothing had happened. I called the dealership I purchased it from shortly after, and scheduled an appointment for 2 days later. They said it sounded like the computer just needed to be reflashed and updated (made sense as its a 14 with such low miles, as it must have been sitting for some time)

2 days go by, and I'm on the way to my service appointment. The same thing happens, except this time I'm going 75mph on the interstate and I tapped the brakes to slow down a bit to change lanes. I pull over on the shoulder, and do the same thing as mentioned above. It turns right over, and starts up.. this time the check engine light comes on. I try and ignore and pray I get to the dealership. About 20miles later, it happens again... this time it wont turn over and my dash is lit up like a Christmas tree and its now saying to Service transmission. 4 hours later, the tow truck shows up and we make the final stretch to the dealership for its appointment. I missed the appointment, and they said it would be looked at on the following Monday..

(its going to get confusing, sorry)
The dealership calls me on Monday, and tells me there is water in the transmission fluid, and it will need a flush and a full diagnostic exam. I notify the dealership I bought my PM from (they cannot service full size PM's for warranty work?) They immediately called the dealership that was looking at my van, and demanded it gets towed to their service department so their transmission tech can look at it. I get a call the next day, and am told there no signs of any water in the transmission or the transmission fluid and they don't know why this other dealership is saying there was. I am also told that it looks like someone had messed with the transmission, and it may void my factory warranty. They then had it towed to their sister store, that CAN service the full size PM and they would let me know what they said..

Another day goes by, and I finally hear back from the 3rd dealership that has seen my PM this week. They tell me they don't see any signs of water damage either, they think the issues are coming from a bad connector and possibly a bad wiring harness, which is causing the voltage to drop and in turn shorts out the computer that controls the transmission. They said that they will be ordering the connector, and once its in they will run another full diagnostic and see if the wiring harness has any faults... AND itll be covered under warranty. 3-4 hours go by, I receive another call from the dealership and they tell that Chrysler and "Star" are now involved.. and my van is 1 of the 5 vans nationwide with this issue and they are doing everything they can to figure it out.


So that's whats been going on.. sorry if its confusing and sorry for its length. If you want me to clarify just ask :) Ive read some posts about people having similar problems, and even saw a youtube video on the same issue. so maybe this will help ?

Thanks guys
 

·
Premium Member
Joined
·
8,809 Posts
I have suspected the failure numbers were low but 5 is a very small number to have any issue. The problem with the diesels may be they are sold in small numbers so even Star sees each failure so few times it is difficult to understand what is going on. I wish the diesel could get back in production so we begin to get correct fixes.
Notice how few emissions issues have surfaced recently? They have a better handle on that.
 
  • Like
Reactions: Blownpotential

·
Registered
Joined
·
155 Posts
Google "Fiat Comfortmatic problems".. there are several issues chronicled by our European friends that sound very similar to yours. 2 easy/common causes are a loose connector in the plastic electronics box behind the main fuse box and an abraded wire/connector caused by the wiper motor rubbing it.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
I received an update on my van, in addition to replacing the bad connector and wiring harness.. I'm also getting a new transmission and valve body at 6k miles. One thing after another...
 

·
Super Moderator
Joined
·
10,140 Posts
That’s unfortunate but at least they seem to be doing something for you now. Don’t allow them to give you any BS about it being your fault tho!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
yeah definitely, very happy that they are replacing it all at once, sucks not having your new van for over 3 weeks once its all said and done (assuming they don't find another problem)
 

·
Premium Member
Joined
·
8,809 Posts
I am happy they are stepping up. What has really failed would be good to know. The complete replacement avoids a buy back for them but we will probably never know what caused the problem.
 

·
Registered
Joined
·
171 Posts
It is faster for them to replace all the transmission with wiring that let the dealership technitians dismantle the wiring, reprogram the transaxle, recalibrate it, ...

Addendum: for model year 2017 the F1C 3.0 diesel engine has its California ARB executive order for emissions.
Date: 20 september 2017.

https://www.arb.ca.gov/msprog/onroa...fptindustrial_mdde_a3960012_3d0_0d20-0d01.pdf

https://www.arb.ca.gov/msprog/onroa...fptindustrial_lhdd_a3960011_3d0_0d20-0d01.pdf

FPT Industrial, part of CNH Industrial, is the manufacturer of the diesel engine.
Till 2012 CNH Industrial was part of Fiat group.
 

·
Premium Member
Joined
·
8,809 Posts
WAHOO! Finally.
 

·
Registered
Joined
·
227 Posts
Mine is going into neutral at stop lights. Started this 2 days ago. These things do not heal themselves.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #13
Hey guys, so I called the dealership to get an update on my van and to see if it was still a go on picking it up today or tomorrow. Unfortunately, its a no-go and the transmission I was told was ordered last week actually wasn't ordered because they are no longer producing that style tranny and the part number has changed on the new one. So I'm get the "latest and greatest" transmission from FCA and I'm placed a backorder list for another 2-3weeks for the new style. Highly considering asking if I can work on my conversion while its sitting behind the shop haha >:)
 

·
Registered
Joined
·
11 Posts
Discussion Starter #14
Mine is going into neutral at stop lights. Started this 2 days ago. These things do not heal themselves.
Sorry to hear your having the same issue, there seems to be very little information on this problem were having. It seems quite uncommon.. and it even has FCA confused (not sure how hard that really is to do though..) Hopefully this new style transmission is the answer to the transmission issue were having. What year is your PM?
 

·
Premium Member
Joined
·
8,809 Posts
Newer transmission? I wonder what changed? I have heard this M-40 is the same tranny used on foot shifters in Europe. I'd bet the changes are small and probably external. Actuators, electronics, or wiring???
 

·
Registered
Joined
·
11 Posts
Discussion Starter #16
Newer transmission? I wonder what changed? I have heard this M-40 is the same tranny used on foot shifters in Europe. I'd bet the changes are small and probably external. Actuators, electronics, or wiring???
I wish I knew more, tried looking it up but nothing found. I'll try and get the part number from the dealership when I talk to them next. The service manager said it was a little more "heavy duty" compared to the other one.. but who knows.
 

·
Registered
Joined
·
155 Posts
It will be interesting to see if it actually is a different part number - I think they might be making up excuses for not getting the transmission in on this one.

AFAIK the transmission is the same unit that is used in the comfortmatic Ducatos since 2006. Maybe they had enough problems in the higher payload diesel promasters that they have beefed up something...:confused:
 

·
Registered
Joined
·
11 Posts
Discussion Starter #18
So guys.. I never really got a clear answer back on the part number for the transmission... but to make a long story short the transmission was on backorder for 3 weeks from Italy and delivered directly to my dealership. After 45 days of the van being out of service (after only owning it for 5 days) the dealership actually bought it back.. which is surprisingly considering it was a used vehicle to begin with. Anyways, I have a since bought a little 93' Astro with 49k miles. so thanks again for all the great information you guys provided, and keep on vannin
 
1 - 18 of 18 Posts
Top