Ram Promaster Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello again. It's been a while since I posted but I'm having a problem with my van. The service transmission light came on while I was driving the other day, then went off but the check engine light stayed on. I took it to my mechanic to get the code read and cleared. It was p0613.

I googled it and apparently it is a fairly generic transmission code which means (a) bad TCM (b) faulty wiring (c) faulty sensors. My truck is still under warranty.

Today it threw a code again and kept flashing until at one intersection it shifted to neutral and would not engage a gear. I restarted the truck and it worked fine but still had the check engine light on.

At the end of the day when I left to go home the check engine light was off. I'm wondering if anyone else has had an issue like this and could help me out. I imagine this means it needs to go to the dealer but was wondering if there is something I should look into before sending it in.

Thanks
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
There are no open recalls on this van. It's an erratic issue. On Wednesday several times I had to restart it because it would gift to nuetral and not shift into drive but by the end of the day the check engine light was off. Yesterday I had no lights and no issues other than at times it doesn't shift as smoothly as it used to.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
So got a call from the dealer today. It is a bad TCM, and they are on backorder. Apparently there is an old part number and a new part number for it. The old one is at least backordered by 300 and the new one is not available. They don't know when it will be either. So I have a van that may or may not stick in gear. It may run just fine some days. Nice.
 
1 - 5 of 5 Posts
Top