Ram Promaster Forum banner

41 - 50 of 50 Posts

·
Registered
Joined
·
13 Posts
Light instantly went off

I just went and added air to the spare for the first time and right away I could see that it was at most about 65 or maybe a tad under that and the sticker calls for 80 in the spare. I probably only added enough to get it up to 73 or 75 I'm guessing. I did check the other tires and they were all close to spec. So I have to assume that the spare was what was causing my light to be on. As soon as I started the van the light did not come on. It did not require any time or driving.
 

·
Registered
Joined
·
106 Posts
Had a crack in the last baffle on the exhaust and had it in to be fixed under warranty. Also asked to have TPMS adjusted to 55 psi all round. Went to pick up and service manager told me could not reset, it comes from the factory that way. REquested he have his master tech double check since this appears to be something many forum members have had adjusted. 30 minutes later TPMS was adjusted to 55 all round and the service manager asked and was granted a tour of the van.:)
 

·
Registered
Joined
·
83 Posts
I have found that the light will come on on a very hot day or a very cold day. There seems to be a 5-10 pound window +-. It also takes maybe 100 KM for it to recalibrate itself. I switch to winter tires and rims in the winter so my TPMS only works in the spring summer fall.

I run 65 pounds year round.

If the spare has a unit in it is an interesting question.
 

·
Registered
Joined
·
1,935 Posts
...cut...If the spare has a unit in it is an interesting question.
Nobody has reported that the factory spare doesn't have one, that said, if I understand these sensor correctly they activate when a rotational force is applied, so only 4 are active.
 

·
Super Moderator
Joined
·
716 Posts
Got tired of that tire pressure warning, asked the dealer to set it to the lowest pressure threshold available, since it can't be disabled. No more warnings.
 

·
Registered
Joined
·
1 Posts
tpms was right and saved my R

Ever since we got our 2018 Roadtrek Simplicity SRT from a previous owner the TPMS has been goofy. I did all the usual stuff and cussed the interfacing with the Roadtrek and temp, pressure issues etc. Put brand new rubber on for a trip West and we came from AZ to Gilroy before the darn light went on again.

I got out the air gauge and checked the tires. the passenger rear read 22.3 psi! I could turn the sensor sleeve with my fingers. Went to Gilroy Tire and Brake and they took a 7/16 combo to the stems and found another loose on the driver's front. They aired them up and the light winked out.

They told me that they are factory items and not checked when they change tires! I could have lost that tire somewhere between Flagstaff and Bakersfield. If your light is wonky please make sure those stems are not loose from the factory or use. That incident scared me into next Tuesday.

best
 
41 - 50 of 50 Posts
About this Discussion
49 Replies
34 Participants
GuyT
Ram Promaster Forum
We’re a community forum dedicated to Promaster enthusiasts to discuss mods, camper conversions, diesel, fuel economy, reviews and more!
Full Forum Listing
Top