Ram Promaster Forum banner
1 - 3 of 3 Posts

Registered
Joined
58 Posts
Discussion Starter · #1 · (Edited)
This is the issue I had 4 renogy flex panels- the company placed them on my 2018 promaster and one flew off - noticed it when I got home - they where not connected in wiring yet _ the panels where purchased in dec 19 then covid - where place on the vehicle 07/21 and the 3 left sat on the top of my roof not wired - took them off on 10/1/21 did I do any damage to them by not wiring- Next issue renogy no longer make 160w flex only 175w flex - can I replace the missing one with the other 3 - 160w flex with no issues or is there a wiring issue - need some help here - the company that f it up are being sued by others at this moment鈥︷煓忦煓忦煒噊so
 

Premium Member
2014, 138WB, High Roof, Gas, SW MT
Joined
2,467 Posts
Hi,
You did not do the panels any harm by not wiring them up.

I don't think you will have any problem using the 175 watt panel along with the 160 watt panel. They are both nominal 12 volt, 36 cell panels. The quoted optimal voltage for the two panels is close.

Just curious - how was the panel that flew off attached?

Gary
 

Registered
Joined
58 Posts
Discussion Starter · #3 ·
Hi,
You did not do the panels any harm by not wiring them up.

I don't think you will have any problem using the 175 watt panel along with the 160 watt panel. They are both nominal 12 volt, 36 cell panels. The quoted optimal voltage for the two panels is close.

Just curious - how was the panel that flew off attached?

Gary
Thank you - screws no bolts馃か
 
1 - 3 of 3 Posts
Top