Ram Promaster Forum banner

1 - 20 of 251 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
Has anybody added rear speakers? When I tap into the rear speaker terminals in the upfitters interface block located in the post between the passenger seat and sliding door I don't get anything. Anybody added any rear speakers?
 

·
Registered
Joined
·
151 Posts
So back to the original question, anyone install rear speakers or has at least looked into installing rear speakers on the Uconnect stereo system?
 

·
Registered
Joined
·
358 Posts
So back to the original question, anyone install rear speakers or has at least looked into installing rear speakers on the Uconnect stereo system?
I did, and they currently don't work. I was told by my dealer that the UConnect system needs a firmware update to allow the rear speakers to function. Was also told the update is a couple of months away. Go figure.
 

·
Registered
Joined
·
279 Posts
Lets take a poll.....How many ppl actually believe (and trust) the dealer.......IME they have no clue what theyre talking about!
 

·
Registered
Joined
·
151 Posts
I did, and they currently don't work. I was told by my dealer that the UConnect system needs a firmware update to allow the rear speakers to function. Was also told the update is a couple of months away. Go figure.
Were the rears installed by the dealer?
 

·
Registered
Joined
·
604 Posts
Lets take a poll.....How many ppl actually believe (and trust) the dealer.......IME they have no clue what theyre talking about!
I just picked one up today. Nobody at the dealership seemed to now a thing about them! If it hadn't been for this Forum I would have been lost. But then again without all these posts filled with answers to my ideas I probably wouldn't have looked at one...
 

·
Registered
Joined
·
253 Posts
I was wondering about this also. Are the speaker connections in the up-fitters harness already amplified, or are they pre-amp outputs? I have a nice set of 6"x9's in boxes that were installed in my '05 sprinter in the overhead that would fill in the stereo quite nicely. I've noticed that if the volume is above about 26 or so, things get a little iffy.
 

·
Registered
Joined
·
358 Posts
Were the rears installed by the dealer?
NO - During the conversion, when the problem was encountered the van was taken to the dealer for unrelated service and they ran at diagnostic and found the firmware issue. The latest update they had did not address the issue, but they said a future update would. We elected to continue with the speaker install - still waiting for the update.
 

·
Registered
Joined
·
151 Posts
NO - During the conversion, when the problem was encountered the van was taken to the dealer for unrelated service and they ran at diagnostic and found the firmware issue. The latest update they had did not address the issue, but they said a future update would. We elected to continue with the speaker install - still waiting for the update.
Ok, good information. Just curious as to where you mounted the rear speakers. Flushed rears, boxed 6x9's? Also did the dealer give ya any timeline on the updated firmware required to run rear speakers with the Uconnect system?
 

·
Registered
Joined
·
810 Posts
I too am interested in adding the rear speakers.

I read the upfitter info. They have a footnote (2), but it isn't explained anywhere.

When I started playing with the radio, I noted that there is not a front/rear setting anywhere that I could find.... hmmmmmm?

Ed
I have the cheap version of the dodge radio..
No CD player or steering wheel controls..
But I DO have a front rear fader option.
Only the front apeaker fade works.
When spun to the rears, silence.
Did you find the separate bass and treble controls?
 

·
Registered
Joined
·
358 Posts
Ok, good information. Just curious as to where you mounted the rear speakers. Flushed rears, boxed 6x9's? Also did the dealer give ya any timeline on the updated firmware required to run rear speakers with the Uconnect system?

Two of these mounted in the ceiling (about 3 feet from rear doors). Sorry, don't have a model number or other info.

These were installed by accident and weren't intended to make the interior into a hifi music venue. I'm fine with the UConnect radio and it's speakers because I use my iPad for Pandora. When/if I do get these working it won't be a big deal.

Dealer said next firmware update in a couple of months would correct the problem - that was a month ago. Going back next month, will see.
 

·
Registered
Joined
·
95 Posts
Luckily in my previous life I worked in automotive for 25 years. Corporate level with GM and Mazda in engineering.

When I first picked up my van in June (after waiting 6 months), the TPMS light came on. I contacted the dealer and was told that my van was the second one with the issue and that an engineer was coming out to try a fix (did not work).
When I met with the engineer, we spoke the same language, so I was able to understand their dilemma and was patient with the repair try.

After he attempted the fix, I explained the other "issues" and he told me he would report it when he returned.

I have been in constant contact with him and another engineer to try and address the other concerns.

As for the radio, I asked the same question about using rear speakers. He mentioned that the conversion market is installing rear speakers by just attaching wiring to the bulkhead connector at the back of the radio. He said it works, but I have yet to try it myself.
He also mentioned firmware upgrades that are coming to deal with other issues with connectivity with Bluetooth and other functions. Could me months away!
Other more pressing issues like the TPMS and break noise and some engine issues.

That is what we get for a vehicle with modules built in Italy, shipped to Mexico for assembly and then shipped to the US and CA.

In the 90's when I was working for Mazda USA we had the same translation issues with the Japanese. They had trouble understanding why an American would complain about something a Japanese driver would not.
 
1 - 20 of 251 Posts
Top