Ram Promaster Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi, I got a check engine light yesterday. :(
I have put about 1000 miles on the van since purchased used. Total mileage is 86K.
I found an OBDLink MX Bluetooth and checked for codes using my smart phone. It was Code P20E8 and it had been reset by the dealer about 1000 miles ago. Did some internet searching, it could be anything from a catalytic convertor to a bad sensor in the DEF system or if it was a Ford, Reductant pressure to low. :D
Hit the clear code button and it cleared, test drove 50 miles so far and checked for codes and it was clear. It has been cold and the van has sat a bit, so hoping something in the DEF system didn't cycle as fast as it should, but is back to normal now... at least that is the hope.
I didn't find the code here on the forum searching, so I thought I would start a thread and keep everyone informed whether it comes back and if it does, what the dealer does to fix.
 

·
Premium Member
Joined
·
8,809 Posts
I don’t think we have seen mention of that specific code but DEF references have been made. I’ll bet you will see it again under some circumstances. If you do try to record what had happened prior to the code in a log. As these vans don’t throw that code yours probably has some issue but probably related to some external condition. I have a 4Runner that throws a catalyst code once a year and resents fine. I have no plan to replace the cat unless that cannot be reset. Sometimes the best code fix is your ODB2 reset button. Best luck.
If the dealer gave you some warrantee that is still in effect i’d be there in a heartbeat and not reset the code. Let them find and repair it.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
RD, I don't think I have much warranty, other than maybe the original 100k one. I probably should have waited and not reset, but the button was too tempting not to press... :D
The dealer still owes me a set of tires, so I will visit when they come in or if the light comes back on..

Van is running fine other than the light incident. Hopefully it was just the temperature changing and not driving for awhile.
 

·
Premium Member
Joined
·
8,809 Posts
I hear you, I got a P2872 code (CLUTCH "A" STUCK ENGAGED) which isn’t, and reset it. No symptoms of anything wrong. Others have gotten it too. My dealer was unhappy I had reset it, but I just couldn’t resist that reset button.... And, seeing that CEL go out, Priceless!
There is a Federal EPA emissions requirement up to 80K miles too I believe, but you are over that as well.
 

·
Registered
Joined
·
1 Posts
No symptoms of anything wrong. Others have gotten it too. My dealer was unhappy I had reset it sorry i cant answer this right now but i will answer you soon give me some time
 
1 - 5 of 5 Posts
Top