Ram Promaster Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Hey I thought I would throw this one out there, just bought PM 2017 159 WB High Roof. I love the space. But the radio volume on the steering broke as soon as I left the lot, so brought it back and they put in the complete new unit. I go to back up and the rear park assist is not working, so they tell me the two are not related and start a new work order, the fix for this was to disconnect the battery under the seat, and this will do a hard reset. OK so this works and the park assist functions normally.
Now the odometer blinks constantly and the service dept said they did not know how to fix this and the van would need to be left with them so they could get someone from dodge to help them trouble shoot.I had to leave so I went back to home.
I tried to do another reset, took the neg off the battery and let sit for about a 1/2 hour. But that is not the fix.

Anyone out there have the blinking odometer?
I will bring it back to the service dept, but I hate little crap like this. I am always amused at what these techs know and dont know.
I googled this and I see I am not alone, but I have not found any real solution to this.
 

·
Premium Member
Joined
·
8,827 Posts
When the battery is disconnected press the brake or some other thing that will drain any residual capacitor to be sure the computers are reset. Easy to try and recommended by others. 30 minutes should have done it.
 

·
Registered
Joined
·
121 Posts
Mine was blinking...it was some module that was bad behind the ac controls... none of the controls were working when mine started blinking...they replaced it under warranty.
 

·
Registered
Joined
·
52 Posts
Mine did that same thing after taking her back to the dealer for a radio swap. When I picked her up, the odometer light was flashing so I turned right around and returned to the service mgr. Turns out the mechanic that did the work didn't exit the computer system correctly! Have em check that...

Sent from my SAMSUNG-SM-N910A using Tapatalk
 

·
Registered
Joined
·
47 Posts
Discussion Starter #9
Thanks, I am bringing her back in. I do not have much faith in the service guys. I will post the results.
They say I have to leave it with them for a few days.
 

·
Premium Member
Joined
·
8,827 Posts
A few days? Thats the time it takes to change an engine not to hook the computer up and check out the blinking dash. I think I’d tell them to call Star and get a plan and call me back when it was going to be an hour service appt. Best of luck on this.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #12
OK the truck is at the dealer, and they just called to tell me its all been fixed, they had to flash the computer .. I wonder if that clears out all of the updates the dealer did before I bought it, I know they had to do some for the trans.
I will go get it and hopefully all is well, everytime they do something with the computer another electrical problem rears its head.
 

·
Registered
Joined
·
538 Posts
When the battery is disconnected press the brake or some other thing that will drain any residual capacitor to be sure the computers are reset. Easy to try and recommended by others. 30 minutes should have done it.

Great idea there! Need to take capacitors into account with all the electronics controlling everything!
 
  • Like
Reactions: RDinNHandAZ
1 - 18 of 18 Posts
Top