Ram Promaster Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
Today it was cold 35 and rainy, happened to glance down at the info center and saw " May be ice on road surface" or something like that
They can figure out the temp and you have wipers on, give a warning for that but no way to get rid of the date on the screen?

Some things puzzle me about this van like having to drive 70 mile or 2 hrs for the TPS to go away only to have it come right back on the next day. I must have checked the pressures 100 times since sept. Just let me know which one is the problem
 

·
Premium Member
Joined
·
8,810 Posts
Checked the spare? Have you had the latest software flash installed? When I did in July the TPMS which had only shown up a couple of time has been tamed. No biggie.
The speedometer should be lighted all the time, and I would like a way to go back through the EVIC options as getting back to one takes 11 jabs on the directional stalk, it is 11 isn’t it?
 

·
Super Moderator
Joined
·
10,208 Posts
It went down to 31° two nights ago and my TPS came on and hadn't gone out since. The tp is is right on and I'm putting my snows on in a few days so not concerned about it. A piece of black tape will "fix" it for the winter as my snows are on a Sprinter rims anyhow!
 

·
Registered
Joined
·
125 Posts
Discussion Starter #4
I checked the spare. I have not brought it to the dealer yet do to a bad experience with a local dealer a few months ago.
 

·
Registered
Joined
·
8 Posts
Every vehicle I've owned with a TPS light ended up with a piece of electrical tape neatly placed over the indicator to block my view of it.
 
1 - 5 of 5 Posts
Top