Ram Promaster Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I just bought a 3500ext with the Tom Tom navigation and its really slow trying to load. I also can't type in a address to go anywhere. Anyone else having problems or know of a way to fix this
 

·
Registered
Joined
·
22 Posts
Tom Tom

PM3500 loaded. I can't get it to program either. When I press Home, it wants to go someplace called Sarillo. Can't find any help online. Going to have to go to the dealer.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
PM3500 loaded. I can't get it to program either. When I press Home, it wants to go someplace called Sarillo. Can't find any help online. Going to have to go to the dealer.
When I got into my truck this evening the maps said loaded. I've put on 200 miles and it finally seemed like it's working. It's really slow to load after I press the NAV button. Everytime you get in to the truck just press the NAV button maybe that will help? does everyone's radio stay on after you turn off the truck? I always have to press the power button otherwise the radio stays on.
 

·
Registered
Joined
·
331 Posts
PM3500 loaded. I can't get it to program either. When I press Home, it wants to go someplace called Sarillo. Can't find any help online. Going to have to go to the dealer.
It probably wants to go to Saltillo. That's where the Promaster factory is in Mexico. That was probably where home was originally set.
 

·
Registered
Joined
·
151 Posts
No the radio just keeps playing. I even walked up the street to see if it shut when the keys went out of range and it was still going.
The alleged Uconnect 5.0 System installed in my PM, which is not in fact a 5.0 system but a much earlier version as verified by the stealership, reacts in this manner:

My Uconnect system offers a "Radio off Delay" option. Go to "settings" then go into “Audio”, then drill down to "Radio Off Delay". There is an option to keep the radio on for a preset amount of time. Ridiculously, the only options are 0 or 20 minutes. No incremental choices are available. Opening the door(s) will not power the radio down if the 20 min option is enabled nor will removing the keys from the ignition! The only way to turn the system off is to manually hit the power knob…
 

·
Registered
Joined
·
26 Posts
Discussion Starter #10
The alleged Uconnect 5.0 System installed in my PM, which is not in fact a 5.0 system but a much earlier version as verified by the stealership, reacts in this manner:

My Uconnect system offers a "Radio off Delay" option. Go to "settings" then go into “Audio”, then drill down to "Radio Off Delay". There is an option to keep the radio on for a preset amount of time. Ridiculously, the only options are 0 or 20 minutes. No incremental choices are available. Opening the door(s) will not power the radio down if the 20 min option is enabled nor will removing the keys from the ignition! The only way to turn the system off is to manually hit the power knob…
Flash Thanks for the info I'm gonna try and find that setting. Wished there were other times other then 0 or 20
 

·
Registered
Joined
·
26 Posts
Discussion Starter #11
The alleged Uconnect 5.0 System installed in my PM, which is not in fact a 5.0 system but a much earlier version as verified by the stealership, reacts in this manner:

My Uconnect system offers a "Radio off Delay" option. Go to "settings" then go into “Audio”, then drill down to "Radio Off Delay". There is an option to keep the radio on for a preset amount of time. Ridiculously, the only options are 0 or 20 minutes. No incremental choices are available. Opening the door(s) will not power the radio down if the 20 min option is enabled nor will removing the keys from the ignition! The only way to turn the system off is to manually hit the power knob…
Thanks flash that fixed the problem
 
1 - 12 of 12 Posts
Top