Ram Promaster Forum banner

1 - 16 of 16 Posts

·
Registered
2016 136WB low roof diesel, converted to an RV by Sportsmobile, TX
Joined
·
420 Posts
Discussion Starter #1
Sometimes, after I have disconnected the battery on my Diesel, the MPG readouts for trip A and B get stuck at 4.7 MPG. I can reset them, and the miles, average speed, and distance correctly reset, but the MPG will instanly updated to 4.7 MPG and won't clear. Multiple engine starts, multiple tanks of fuel, nothing will reset this. Again, *sometimes* disconnecting the batttery will fix it. Sometimes it won't. Has anybody else seen this? any suggestions on fixing it?
 

·
Premium Member
Joined
·
8,827 Posts
I think you posted this up earlier and IIRC no one had then and still no one has. You are a pioneer! Sorry. If you can get it working when reset with a battery disconnect I’d complain to the dealer and show them, get a Star case started, then if no help is forth coming I’d reset it to work and move on. Just make sure FCA has a record so later when it really fails you get it fixed on their dime.
 

·
Registered
Joined
·
121 Posts
I posted the same problem when my van was brand new in March but a battery disconnect for a minute cured it. It never reoccured. Sounds like a dealer issue.
 

·
Registered
2014 Ram Promaster 2500 159" diesel
Joined
·
1,480 Posts
There's a service bulletin dated 11/15/2016 out I posted on "List of service bulletins" thread. A dealer visit is required for a flash.
Sometimes, after I have disconnected the battery on my Diesel, the MPG readouts for trip A and B get stuck at 4.7 MPG. I can reset them, and the miles, average speed, and distance correctly reset, but the MPG will instanly updated to 4.7 MPG and won't clear. Multiple engine starts, multiple tanks of fuel, nothing will reset this. Again, *sometimes* disconnecting the batttery will fix it. Sometimes it won't. Has anybody else seen this? any suggestions on fixing it?
 

·
Registered
Joined
·
2 Posts
electronics / 4.7 average economy reading

Did wowbanger ever resolve his 4.7 issue?

I just replaced my 2016 promaster stock defective battery with a interstate battery and afterward noticed that my average economy was stuck at 4.7 for trip a and b and won't reset. I had it at a local dodge dealer today for several hours and they can't figure it out even after consulting Fiat Chrysler. Fiat Chrysler has no idea.The dealer even disconnected the battery per someone else's suggestion on the forum with no luck. I bought this unit last september and has barely any miles on it. I have to bring the promaster back in and leave it with them until they can figure it out.

Anybody else with similar problem?
 

·
Registered
Joined
·
24 Posts
This is most helpful. I too have had the 4.7 MPG problem on my 3500 Diesel. I have tried the battery disconnect to no avail. I was into a Dealer in Bozeman MT yesterday and I was told the dash cluster had to be replaced. The catch 22 on that is they need to keep your van until the part comes in so the mileage is the same as when ordered. Order time from 1-6 months. What a helpful warranty repair that is! I will refer to the service bulletin and see if its worth training the dealer on the flash fix. Other than that the van has been flawless at 7,000 miles (knock on wood).
 

·
Registered
2017 136” HR
Joined
·
283 Posts
I have the same problem. After disconnecting the battery to install my swivel seats my mpg is stuck on 4.7 as well.
 

·
Registered
Joined
·
145 Posts
I had the same problem on my gas Motor Home after the dealer did the transmission recall. MPG stuck at 4.7 mpg even after resetting. Took to dealer and they did an IPC flash of the computer (cost me $284.05) from the service bulletin for issue. I am not happy that I was charged by the stealership.

MLogan
2017 Trend
Smyrna, TN
 

·
Registered
Joined
·
608 Posts
It sounds like corrupted data in non-volatile memory. Overwrites the volatile memory and/or doesn't update with usage to copy back. makes sense to me, but I could be way off. Perhaps there's a way to access this in using an obd app or dongle? Might need one of the extra fancy level ones
 

·
Registered
2016 136WB low roof diesel, converted to an RV by Sportsmobile, TX
Joined
·
420 Posts
Discussion Starter #12
About all I can suggest, if the dealer won't/can't fix it, is just keep pulling the battery, waiting 10 minutes, and trying again.
 

·
Premium Member
Joined
·
8,827 Posts
10 minutes may not do it. To reset the several computers that control the vehicle you must bleed out many small residual charges. To do that apply the brakes and the electricity will be drained through the light filaments. Capacitors can store electricity almost indefinitely unless it is bled off.
 

·
Registered
Joined
·
2 Posts
I just had this happen to me today on our 2017 Durango, I noticed when I went to fill up that it said 4.7mpg, didn’t think much of it, reset it and it started working after fuel up. However after stopping and restarting it reverted back to 4.7. I tried resetting the battery at 10min/time about 5 times, no fix... Does anyone know the TSB number or where I can locate it, looks like a trip to the dealer...Thanks
Fueling up was an issue too, if stopped early according to the gauge, I thought it was a pump issue so I went to start pumping again and it kicked some fuel out, the gauge never went all the way to Full so I don’t know if this is related or just a pump issue, and coincidental....or if I have a gauge/sending unit issue too....
 

·
Registered
2017 136” HR
Joined
·
283 Posts
I believe this is it?
 

Attachments

1 - 16 of 16 Posts
Top