Ram Promaster Forum banner

1 - 20 of 25 Posts

·
Registered
2017 159, w/dual sliders. SF Bay area
Joined
·
1,031 Posts
Discussion Starter · #1 ·
When using the fob to lock the doors on my 2017, the parking lights flash and the horn sounds. Then the lights stay on for a moment before going out. The parking lights then flash briefly every few minutes (I have not timed it.) Pressing the lock button again turns off the lights completely.

Of course I can't find anything in the manual like this.

Suggestions?
 

·
Registered
Joined
·
142 Posts
When using the fob to lock the doors on my 2017, the parking lights flash and the horn sounds. Then the lights stay on for a moment before going out. The parking lights then flash briefly every few minutes (I have not timed it.) Pressing the lock button again turns off the lights completely.

Of course I can't find anything in the manual like this.

Suggestions?
Not sure if this is the issue but mine will flash if I try to lock the doors and the doors are not fully closed. I can't lock it until all the doors are closed. I always corrected the issue right away so I am not sure what it would do if the doors remained open? Maybe it would continue to flash every few minutes?

Sent from my SM-N950U using Tapatalk
 

·
Registered
2017 159, w/dual sliders. SF Bay area
Joined
·
1,031 Posts
Discussion Starter · #3 ·
Yeah, I should have done some more rigorous testing. I thought about the door not closed issue. The manual says that the horn will not sound if a door is not closed. I'll have to pay more attention to that.
 

·
Registered
Joined
·
83 Posts
My 2017 only flashes the park lights when locked with the fob. Do you have a security system? Is that even a promaster option? My pilot honks the horn when the doors are locked and security system is activated?

Sent from my SM-T560NU using Tapatalk
 

·
Registered
Joined
·
142 Posts
My 2017 only flashes the park lights when locked with the fob. Do you have a security system? Is that even a promaster option? My pilot honks the horn when the doors are locked and security system is activated?

Sent from my SM-T560NU using Tapatalk
Same here with my 2017. Lights only. Maybe a system setting?

Sent from my SM-N950U using Tapatalk
 

·
Registered
2017 2500 HiTop 159 Cargo Van white.
Joined
·
529 Posts
I would love to turn off the horn on in my 17 2500. I hate the thing. Lights blink, OK. Horn honk, Ahhhhh.
 

·
Registered
2017 159, w/dual sliders. SF Bay area
Joined
·
1,031 Posts
Discussion Starter · #11 ·
Thanks for all the ideas. Yes, I have a security system. Yes, I think there is a setting in UC5 to kill the horn. I have to double check that. So, nobody else has their courtesy lights stay on and periodically blink? I'm off this week, so I'll have time to do more controlled testing. - an install running boards, swivels, maybe windows, side cameras, and a floor - oh my.
 

·
Super Moderator
Joined
·
10,635 Posts
This must be an option for later models as my ‘14 doesn’t blow the horn when locking.
 

·
Registered
2017 2500 HiTop 159 Cargo Van white.
Joined
·
529 Posts
Just went thru the UC5 menu, inside and out. I cannot find a way to turn off the horn beep on locking from the fob. ****, I hate the that horn.

2017 159 hitop gas.
 

·
Registered
2017 159, w/dual sliders. SF Bay area
Joined
·
1,031 Posts
Discussion Starter · #14 ·
Closing the loop on this. Yes, it was possessed. I pulled the power to install the swivel bases. After that, the alarm behaves in the expected manner - a single button press honks the horn and flashes the lights one time.
 

·
Registered
Joined
·
74 Posts
I have the flashing also. 2018 159" high top, gas.
It seems to have recently started.
About 2 weeks ago, I disconnected the battery to add a fuse, nothing is connected to the fuse yet.
This appears to have started within the last week.
There is absolutely nothing else contacting/shorting/completing the circuit for the fuse.
The engine starts as normal as ever.
All doors are shut flat. Windshield, driver and passenger windows only. Both driver and passenger windows are up/closed.
flash once,
then after approx 30 seconds,
flash twice,
then after approx 30 seconds,
flash once,
then after approx 30 seconds,
flash twice....
 

·
Registered
Joined
·
74 Posts
Solved.
Possibly....

Previously (after disconnecting and reconnecting the battery)....
I had to press the unlock button twice so that the mirror, front and rear lights would not stay on or flashing.
When locking, I had to press the lock button twice so that the lights on the mirror, etc., would turn off.
Honk, honk.

I had left the key in and at the first click when I disconnected the battery previously.

I took the connector off again and then reconnected.
No key in.
I pressed the lock button and the lights flash once; no lights staying on, no odd flashing of external lights.
 

·
Registered
Joined
·
15 Posts
Closing the loop on this. Yes, it was possessed. I pulled the power to install the swivel bases. After that, the alarm behaves in the expected manner - a single button press honks the horn and flashes the lights one time.
Did you just disconnect the battery? Running into the same possessed issue.
 

·
Registered
2017 159, w/dual sliders. SF Bay area
Joined
·
1,031 Posts
Discussion Starter · #20 ·
Did you just disconnect the battery? Running into the same possessed issue.
Yes. I just disconnected all the battery. It was probably off for 2 hours, but I'd guess just 5-10 minutes is probably enough.
 
1 - 20 of 25 Posts
Top