Ram Promaster Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
Has anyone got there iPhone to connect to basic stock radio or uconnect for that matter....
 

·
Super Moderator
Joined
·
8,323 Posts
Mine works perfectly iPhone 4 (iOS 7.1.1)with uconnect. The gps is another story but supposed to be switched by the dealer tomorrow.
 

·
Registered
Joined
·
56 Posts
Mine works great--blue tooth phone calls, pandora, siriusxm radio, iPhone mapping, etc. Actually like it better than the set up in the Toyota Prius.
 

·
Super Moderator
Joined
·
8,323 Posts
Does anyone know if there's a way to get google maps or apple maps to show up on the uconnect screen?
Unfortunately, the simple answer is no:crying:

There is some add on aftermarket conversion module that will accomplish what you want but I believe it's in the $300 range. Try googling uconnect iPhone/ipad I know you will find it.
 

·
Registered
Joined
·
6 Posts
i have an iPhone 6, uconnect and my bluetooth is spotty at best. Many times the radio doesn't recognize the phone when I hit the Media button. Have even had the radio not recognize the phone when I wanted to make a call. Am having the dealership take a look at it, hopefully today if they have time.
 

·
Registered
Joined
·
238 Posts
i have a 6 plus and that has maybe happened once or twice...ive had the same issue with other bluetooth devices, so i think its more bluetooth than uconnect...its 2015 and electronics still arent perfect, didnt we go to the moon like a long ass time ago?
 

·
Premium Member
Joined
·
84 Posts
I had intermittent problems with my 5s and when I took it into the dealer they decided I needed a new radio. I should be getting one in the next week or so. I had asked the dealer to reinstall the software as that what I figured was the problem, but they wanted to put a new radio in. Todd
 

·
Registered
Joined
·
890 Posts
It is a tad flakey with my 5s. Usually works, but sometimes it forgets its paired.

One complaint is that i also use an old iphone usb'd as an mp3 player. No matter what i do, no matter how i set it, ever time i start the van it starts playing ac/dc because its alphabetically first. Annoying.
 

·
Registered
Joined
·
279 Posts
If my radio is off, and I get a call, when I hang up it always stays on. Sometime really loud. Scares the daylights outa me!
 

·
Registered
Joined
·
890 Posts
There's a setting in the Uconnect 5.0 that supposed to let you choose if you want the radio to default off, or if you want it default on and playing the last thing you had playing. No fiddling with this seems to make a difference....AC/DC weather you want it or not.

Another niggle: often times I have to jump in and back up a loading ramp. When the PM is in reverse, the backup camera is on, and while the camera is on the radio controls are blocked out. Volume included. So I jump in, start it, put it in reverse, and then I get AC/DC at full blast and there's nothing I can do short of putting it in drive to turn it down. Meanwhile, the dock guys are looking at me like I'm an idiot having a rock moment while I'm backing up. Maddening.

Perhaps the solution is to create an MP3 named AAfirst, and have it be either just dead air, or maybe it be the sound of a truck backing up.
 
1 - 18 of 18 Posts
Top