Ram Promaster Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
I have a 2015 Diesel Promaster. Several months ago it starting making a growling sound under the hood for a few seconds after the ignition was cut off. Then the same growling sound begin while the engine was running after it warmed up. It was caused by an electronic solenoid part #68250450-AA . Apparently it is not an off the shelf item since it took a week to get. If you are having that sound, this could be your problem.
 

·
Registered
Joined
·
227 Posts
were you having any other issues besides the noise? also has anything else changed since the part was replaced? did the noise go away?
 

·
Registered
Joined
·
734 Posts
I have a 2015 Diesel Promaster. Several months ago it starting making a growling sound under the hood for a few seconds after the ignition was cut off. Then the same growling sound begin while the engine was running after it warmed up. It was caused by an electronic solenoid part #68250450-AA . Apparently it is not an off the shelf item since it took a week to get. If you are having that sound, this could be your problem.
I have that noise when the van is shut off. It's a 2014 gasser. Never heard it while running. Other than the noise, is there any other reason to fix?

Sent from my SM-P900 using Tapatalk
 

·
Registered
Joined
·
227 Posts
I have that noise when the van is shut off. It's a 2014 gasser. Never heard it while running. Other than the noise, is there any other reason to fix?

Sent from my SM-P900 using Tapatalk

There was another thread about noises from the diesel. I had described mine as more of a honking sound, several others said that honking was a great description of their noise too. I wonder if this is what he is calling a growling noise.
I can live with the noise, but I wanted to know too if there were other issues performance wise.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #5
growling sound

I had the sound coming from the Diesel for a year. It did not seem to cause a problem. Only recently did the same sound start while cruising at 60mph. I was concerned it would leave me if i did not fix. The dealer seemed to think it was important to fix. It took about a week to get the part.
 

·
Registered
Joined
·
2 Posts
Which part?

I had the sound coming from the Diesel for a year. It did not seem to cause a problem. Only recently did the same sound start while cruising at 60mph. I was concerned it would leave me if i did not fix. The dealer seemed to think it was important to fix. It took about a week to get the part.
Mine has this sound too. (diesel 2016). Which part was replaced? My dealer in Montreal doesn't seem to be aware of that sound problem. Is it the solenoid you're talking about in the original post?
 

·
Registered
Joined
·
27 Posts
I had the same sound for about a year and it was caused by the turbo actuator: It finally caused the truck to go into limp mode. Dealer replaced it and so fr so good.
 
1 - 7 of 7 Posts
Top