Ram Promaster Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter · #1 ·
So a couple days ago when I first start the Promaster all is fine till I got about 1000 feet up the road. The red lightning bolt would flash. A restart and it went away.

It did the same thing last night, but this time with the restart the check engine light came on and the red lightning bolt still flashed. After the Promaster got to operating temperature and a restart the lightning bolt would go away. So I pulled the code it was P04D9. I then cleared the code.

Now this morning same thing lightning bolt, restart lightning bolt and check engine. So I just dropped it off at the dealer. Service written said the code is P04D900. Told me the mechanic that works on the Promaster won't be in till later today, so they gave me a Jeep Patriot as a loaner.
 

·
Registered
Joined
·
351 Posts
That's a different code from what I got on mine. They're replacing a good part of the wiring harness on mine. I haven't got the details yet.
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #3 ·
I just pulled out of the parking lot, and the Jeep Patriot loaner lost all power. Wow talk about some rotten luck. This thing only has 19 miles on the clock.
 

·
Registered
Joined
·
351 Posts
WOW! That does suck! They gave me a Jeep Renegade, It's kinda cute and no problems so far!

Good luck!
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #7 ·
So I put on 250 miles since I picked up the Promaster after they flashed the new software onto the PCM and the BCM. no more flashing thunderbolt and no more check engine light.
 

·
Premium Member
Joined
·
8,838 Posts
Another, it is getting so I almost can tell you the month! It seems that the DEF/CEL codes happen to vans built before about March-April/2015 We have yet to hear of an April/May or onward with this nuisance code issue IIRC. Some members offer up odd fixes such as new DEF tank or injector(?) or new wiring harness but most have a ECM flash and/or the van fix itself!!! What changed at that time would be good to know. As time goes on it looks like this issue will go away now that fewer of the 2014 and early 2015 built vans remain on lots.
 

·
Registered
Joined
·
257 Posts
I bet the only thing that changed at that time was a new mapping/ECU. They had a few months of issues by that time, fixed them in the field with a reflash (after trying a lot of parts swapping) and then rolled the ECU change back into production as an Engineering Change Order.
 

·
Registered
Joined
·
142 Posts
Same here, had some dash lights, got my flash done, all better.

The PM is one of the best vehicles I have ever driven.

The dealer stuff is a pain, our nearest is 3 hours away.
 
1 - 16 of 16 Posts
Top