Ram Promaster Forum banner

Have you had any emissions related issues with the diesel

  • No DEF, Regen, or emissions issues

    Votes: 26 53.1%
  • Issues but fixed/addressed right away

    Votes: 9 18.4%
  • Issues but took week(s) to fix

    Votes: 5 10.2%
  • Issues but never were fixed or took a long time to address

    Votes: 10 20.4%

  • Total voters
    49
1 - 20 of 32 Posts

·
Registered
Joined
·
247 Posts
Discussion Starter #1 (Edited)
Thought we might try to just document the diesel performance along with a poll for the emissions/engine issues

2014 159 2500 VIN 1257XX
3500 miles
Best MPG 26
Worst MPG 22
AVG 24

No issues
 

·
Registered
Joined
·
625 Posts
My only issue so far with the diesel is that I don't have it yet. :( Need to check in with the dealer this week, its been awhile since I've been over there.
 

·
Registered
Joined
·
96 Posts
Oh Yeah!!! 2014 PM 3500ext. EGR fail @ 2800 miles, no resolution for 41 days, picked up on A Friday nite, drove 78 miles, CEL hand TCM lights resulting in LHM. Back to dealer. Said PCM was bad, none available. After HOT emails to District Ram Mgr and National Ram Customer relations Director, approved for buyout and replacement. They ref lashed the PCM and applied dielectric grease to the Crankcase sensor, and returned to me. Had a CEL and TCM episode @ 3800 miles. TCM did not come on after restart w 10 minute wait. CEL remained on all day, and finally went off after a couple of hundred miles. NOW >6000 with no further incidents, so far. Have a 2016, gasser on order, due to be early production w FCA flag as replacement.I'm hoping it'll be here in August, waiting on VIN assignment and build date. I would rather have the diesel, but just don't trust this truck, or FCA's ability to service any issues that may arise. Doesn't seem that they were prepared for the PM rollout, specifically parts availability and the fact you have to find a PM certified dealer means I could get service here, but out of luck on the road. FCA really needs to RAMp up (Pun intended) their program, because this is absolutely the best van I have ever driven, I've driven 5 new PM's since Jan, 3 gas and 2 diesel, and they were all a joy to work out of. The diesel loaner failed with EGR fail @ 1800 miles too, and it's VIN was 1 digit more than mine.
 

·
Registered
Joined
·
11 Posts
2014. 3500 Hightop diesel Ext . The day after I bought the van I get a code and have it cleared....next day I head out on a 8,000 mile planned trip. Traveled Across the States to NYC then down to Miami and then all the way to California....no codes but one....on the last day of the trip...same one...cleared it and drove the remaining 800 miles in one day home. Van was so much fun to drive. Love it! Every time we would see another Promaster we would get all excited!
Would recommend this van to anyone that is thinking about buying a larger Van. Front wheel drive is fantastic! Can turn on a dime. We are at 11,300 miles today...running great.
See you on the road
 

·
Registered
Joined
·
5 Posts
2015 diesel window 159 hightop. Took delivery 3-9-15. At 45 mileage, "ETC" (Electronic Throttle Control) started blinking, then the "MIL" (Malfunction Indicator Light) came on. Shut down, restarted, only MIL stayed on, not blinking. Talked to the shop, and they indicated that it was probably software, and that if it was blinking, it could be serious and bring it right in. If it was not blinking, bring it at some point. The next day the lights were all gone. This happened 4 times in the first 150 miles, then all went away, no lights, no problems. Currently at about 800 miles.
 

·
Registered
Joined
·
31 Posts
I have a 2015 diesel cargo van 136wb hightop. I took delivery at the end of March. 2 days later. I had a multitude of dash lights come on. I was told nothing was wrong, that it was caused by ice build up on the vehicle.?? A week later I got the ETC light along with the check engine light. When the ETC light comes on, the vehicle immediately loses power. I have to pull over shut it down and restart, in order to drive it. It does this about once a week. [except for one time it went about a month]. So far the dealer has no answers. [and unfortunately it sounds like Chrysler has no idea what is going on either?]
 

·
Registered
Joined
·
3 Posts
2015 Diesel 1500 w/ 22,000+ miles

This is a great van when it is running properly. 23 mpg and comfortable. From the very beginning I have had numerous transmission and computer problems. 10 months later and I have lost track of the number of times I have had it into the dealer, sometimes for more than a week. The dealer drives it about 5 miles updates the computer and tells me they could find nothing wrong. According to them I am the only van with these issues except the low brake fluid indication.

Flashing etc (electronic throttle control) light + service engine light. I lose some or most power and have to stop, sometimes in traffic on the highway, shut the van off and turn it back on to get power. 3 times today alone.

Transmission diengages the clutch, the dash tells me to shift to neutral and it won't re engage the clutch until I have come to a stop and turned the engine off for a few seconds to a few minutes. This has also stopped me in center highway lanes. No indicator lights associated with this.

Once in a while I get extremely short first gears, shifting into 2nd way too early leaving me with no power. This usually happens when I am trying to jump into heavy traffic with 3/4 or better throttle. No wheel spin is associated with this. The van usually creeps out when this happens as if I am not giving it much throttle.

Manual mode - trannsmission skips 3rd once in a great while.

Transmission grinds gears once in a great while. Occasionally occurs around the time of it disengaging the clutch and telling me to shift to neutral.

Transmission dumps the clutch on rolling stops causing the tires to bark or spin.

Below 50 degrees the clutch releases normally until suddenly locking, jerking the van with every shift.

Low brake fluid indication with the level above the midfull line.

Random service engine lights that are not associated with other idiot lights or dash messages. One of these frequent codes is for an over pressurized crank case.
 

·
Premium Member
Joined
·
8,719 Posts
6/2015 build
2,800 miles
Best tank of fuel 28.9
worst 26.1
no lights, no codes, runs great
no issues except TPMS has come on twice w/o low tire, not an engine issue

PLEASE include build date as there is a time that most problems seem to have ended and knowing when that is would help prospective purchasers. Thanks
 

·
Registered
Joined
·
184 Posts
2015 118" diesel, build date 10/2014.
replaced turbo.
8000 miles, runs awesome!
After test driving the others, you cant beat the handling of the PM!
Half way through the conversion.
The PM is my everyday driver.
 

Attachments

·
Registered
Joined
·
3 Posts
2015 Diesel 1500 w/ 22,000+ miles

My build date is 10/14

My van has been in again and has been declared a "star" vehicle. They want it for 4 to 30 days to determine the problem.

My ongoing short first gear issue is a known problem which Ram has not found a solution to. "D" mode shouldn't be used when acceleration is critcal according to my dealership.

The transmission is now leaking oil down both axles. The reservoir, for some reason, is covered in oil now. I will be adding oil for the first time tomorrow.
 

·
Registered
Joined
·
17 Posts
2015 3500 extended.
25000 miles so far. Coolant loss has been a "slight" issue. Twice when refilling the windshield washer fluid, I have noticed the coolant reservoir was below the min line. When getting an oil change at the dealer I asked them to look into the loss. They pressure tested the truck cold, and hot, and could not find any issues or leaks. I have not had any codes or cel lights so far. The fluid level does fluctuate quite a lot.

Otherwise, truck has been great. I do find the tranny holds 3rd gear quite a long time before going into 4th.

After 25k my trip computer shoes an average of 28mpg....typical load of around 1800lbs. 90% hwy use.
 

·
Registered
Joined
·
30 Posts
I have a 2014 159" diesel. I've had it little more than a month. A little over 3K miles, no problems. (I'm hoping I got lucky, hearing about some of the issues).
I generally drive it in the manual mode and "short shift" it. I feel the D mode revs it out much more than it needs.






So far pretty happy with it. Getting between 22-24 mpg. Mixed use, its my everyday driver.
 

·
Registered
Joined
·
227 Posts
2014 159" High Roof. build date 10/07/14.

At 59k miles had transmission issues of not going into gear, after sitting for a few minutes and a restart it would go into gear. I had it worked on at a dealer that replaced: clutch, clutch actuator, master cylinder, & slave cylinder. Van worked fine for another 58k miles. Last week it started jumping out of gear and would only go into gear after a restart. It will not go into reverse at all now. The van is currently at the same dealer and I have contacted Ram for assistance.
 

·
Registered
Joined
·
1 Posts
Service DEF message

Got the dreaded message, telling me I had XXX miles to go, see dealer. Since I was on the road on a Friday, far away from selling dealer, had to research. Turns out that the dealer in Duncannon PA is first rate for diesel, he downloaded a flash update. It took about 100 miles to clear the dashboard of the scary message (he told me that), but then I got my dashboard back and it runs perfect. This happened at about 12K miles.

Good to have your computer updated when in for service, which we will do from now on, and ask if there are any TSB's related to your van that need attention.
 

·
Registered
Joined
·
227 Posts
5 WEEKS BROKEN
one year ago today the van was brand new and we went to Cleveland OH. Today the van has been at the shop for 5 weeks now. The transmission has broken for the 2nd time. The shop has put the van back together, but it is still throwing codes and jumping out of gear. I have lost all confidence in this van on being able to earn a living with it.
5 WEEKS BROKEN STILL
the transmission broke at 59,000 miles back in December and was patched up to satisfy warranty requirements. Then it broke again at 116,000 miles (another 59k). this time gears were broken and all; the shop has put the van back together but it is still throwing codes and jumping out of gear. The tech team from Ram USA has given up on finding a solution. I was informed Thursday that a tech team from Italy is going to offer their help and insight. I have zero confidence in a real solution that can be found so that this van will be trouble free to earn a living.
5 WEEKS BROKEN and now I am BROKE TOO
 
  • Like
Reactions: HVAC1957

·
Registered
Joined
·
625 Posts
Yes, Ok, we get it... your PM is broken. All vehicles out there have some catastrophic failures. It happens. It sucks that it happened to you (or anyone). But spamming the forum doesn't help much. There's folks that have had Sprinters go kablooie. Fairly sure I've read about some serious Transit problems too. Even Honda and Toyotas and such too... Take your pick... Life just dealt you a crap hand right now. Again, sorry about that... but deal with it constructively instead of whining about it.
 
1 - 20 of 32 Posts
Top