Ram Promaster Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I was driving home from the dealership with about 125 miles on the odometer when the evic announced DEF Service Engine Soon 200 miles until reduced power. This was a 2014 model so I'm sure it had some old DEF in it before the dealer topped it off with new. My question is should I have them just clear the code and then run it to see what happens or should I let them work on it? Or maybe there is a 3rd option. I would love to clear the code myself and see it reappears.

As it is the van runs great and is getting great mpg's.

Any advice is appreciated.
 

·
Registered
Joined
·
351 Posts
I was driving home from the dealership with about 125 miles on the odometer when the evic announced DEF Service Engine Soon 200 miles until reduced power. This was a 2014 model so I'm sure it had some old DEF in it before the dealer topped it off with new. My question is should I have them just clear the code and then run it to see what happens or should I let them work on it? Or maybe there is a 3rd option. I would love to clear the code myself and see it reappears.

As it is the van runs great and is getting great mpg's.

Any advice is appreciated.
Welcome.

I got the same error on mine (Build date 1/15) at 600 miles. It's at the dealer right now, they've replaced the DEF tank, and are in the process of swapping out the wiring harness on the left side of the van(Service Managers description).

Good luck!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks Quest4adv.

I took it to the dealership, condition not present, so they cleared the code and all is well. I attribute this to the little bit of old DEF that was in the system from the factory.

Engine is running fantastic and I like it a lot. 25.6 mpg according to the computer.
 
1 - 3 of 3 Posts
Top