Ram Promaster Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter · #1 ·
there is an existing connector installed in above the back door of every 2014 promaster to plug in a camera. why then do all the aftermarket cameras specific for the 2014 ram promaster include all the extra cable to run a redundant 25' camera backhaul? why do they not simply include the proper connector? (which are probably impossible to get, ive searched and searched!)
Anyway according to the up-fitter documentation, the power feed is "generic ignition run". Does this mean it will be on when the ignition is on? How is it that the oem camera install only comes on in reverse? My install will include an aftermarket headend and aftermarket camera and I would like to use this camera backhaul however I want my camera on full time when i select it on my headend. thanks!
 

·
Super Moderator
Joined
·
10,659 Posts
All you have to do is ground the camera wire to turn it on full time (with the OEM camera). It's well documented here if you do a search.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #3 ·
Behind the radio There are only three wires; white, red and black according to the up-fitter pdf. {video signal and video ground and video signal return}. Therefore, maybe I have to run another harness for power or else deal with the power-on-reverse issue? So this existing power wire for the camera is setup to only run while in reverse or is that a function of the uconnect?

Also my wire colors dont match the wire colors mentioned in the pdf. DB/DG? i have a light blue with light green and also a black with purple stripe
 
1 - 3 of 3 Posts
Top