Ram Promaster Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
I am about to pickup another promaster and this one has the 5.0 screen but no camera. It has the prewire for the camera and I have seen the wiring diagram but no one at the dealership knows if the head unit will accept the signal from a aftermarket camera.

Does anyone know if the radio can be made to display the image from a non factory camera?
 

·
Super Moderator
Joined
·
9,062 Posts
If it has the input wire for a camera I don't see why not. I think back up cameras are pretty much low tech and all work pretty much alike
 

·
Registered
Joined
·
110 Posts
I agree. There was another post that showed something to do with the backup camera. Have you used the search bar to see what you can find buried on the forum? Even so, hooking up the camera should be easy if you have any electrical experience.
 

·
Registered
Joined
·
258 Posts
The trick is to switch to the appropriate input on the screen. I have some schematics that I can email you. Send me your address and I'll look for it this afternoon.
 

·
Registered
Joined
·
25 Posts
also interested in connecting the rear camera on Winnebago Trend to the Uconnect 5 screen, the tiny mirror screen is too hard for my wife to see and hope that the factory promaster camer input for the uconnect would work
 

·
Registered
Joined
·
129 Posts
There is a backup camera specifically for the PM listed on Ebay. Costs almost as much as the factory option though.

If anyone is looking for doing the reverse of this - different deck, but retaining the functionality of the Uconnect (steering, camera input, bluetooth, etc) - we used these in our Chevs - http://www.ebay.com/itm/261516271998?ssPageName=STRK:MEWAX:IT

Dual-din - I have NOT installed one in a PM, nor do I own a PM yet, working on that ..>!
 

·
Registered
Joined
·
57 Posts
Discussion Starter #9
Finally got around to tinkering with the backup. Here is what i tried....

Promaster #1 = 2500 with factory backup
Promaster #2 = 1500 with 5.0 no camera.

Moved the factory camera from PM 1 to PM 2 to see if i could just order a factory camera.
Nothing happened when shifted into reverse. Radio screen only.

Ended up removing center red light and modifying that location for a aftermarket system from Amazon.com. Install worked well with an aux 7" screen mounted in overhead console.
 

·
Registered
Joined
·
1 Posts
I too bought a Promaster City SLT and it came with everything except the camera. The dealership wants $900 to install the camera. Did you find a solutuon?
 

·
Registered
Joined
·
5 Posts
Hi,
Bought this: https://www.amazon.com/gp/product/B01NA71QRE/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1 About $125 for the camera in what looks like a factory housing. You have just four connections: Video out plug (inside this is the video wire and the shield) and power (a black and red wire).

It all fits BUT the van is not providing power to the camera wires. Tried it with the back doors open and in reverse.


BLU/LT GRN
- 12V from the Body Control Module The module is powered directly from the battery with an always on connection so
the module decides what gets power and when. (Difficult to see the colors but if you look closely you can see the
stripe)
WHT - (Actually Clear) is Camera Return
RED - Camera Signal
BLK - Camera Shield
BLK/VIO - Ground Be careful here this almost looks like black

Most cameras just have two wires. The signal and the ground/shield. So I am not certain here if we should connect the camera to the Shield or Return. Return is a new thing to me. However, since I am getting no power from the BLU/LT GRN wire not important now.

The power comes out of the Body Control Module. I am guessing this means that the dealer will have to turn on power to the camera in that module.

Anyone have any ideas on this?
 
1 - 14 of 14 Posts
Top