Ram Promaster Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
469 Posts
Discussion Starter #1
So last night on my long drive home from work about an hour into my drive in heavy rain and wet roads the dash lights up with all the warnings in the title. I'm thinking something like and ABS sensor got wet and caused this light. anyone else ever come across this problem or have a fix. and I doubt it but would this be covered under the powertrain warranty? I'm at 48,000 miles gasser. Thanks
 

·
Registered
Joined
·
108 Posts
Awhile back I ran thru standing water and dash lit up like a Christmas tree! It took about a week and the lights went off one by one. Airbag light is the only one that hasn't gone off.
 

·
Registered
Joined
·
469 Posts
Discussion Starter #3
Awhile back I ran thru standing water and dash lit up like a Christmas tree! It took about a week and the lights went off one by one. Airbag light is the only one that hasn't gone off.
Thanks that's what I'm hoping for but its gonna drop down to -1 tonight so whatever got wet is now going to expand lol
 

·
Registered
Joined
·
7 Posts
cold days here and occasionally air bag lights comes on and off. can you scan for codes...maybe that could help with finding solution. good luck and hope to be free of charge and fast resolved.
 

·
Registered
Joined
·
14 Posts
ABS, ESC, Hill Assist

I'm getting the same error messages (17 gasser with about 25k miles). They seem to come and go over the past few days. I have a pretty long trip coming up at the end of the week and of course the dealership is booked until next week. I've been reading that in other vehicles this can be solved by replacing the brake light switch. I can't seem to get any codes on the ODBII reader, so I can't quite tell what is going on. Anyone found a resolution and maybe a DIY fix?
 

·
Registered
Joined
·
469 Posts
Discussion Starter #7
I'm getting the same error messages (17 gasser with about 25k miles). They seem to come and go over the past few days. I have a pretty long trip coming up at the end of the week and of course the dealership is booked until next week. I've been reading that in other vehicles this can be solved by replacing the brake light switch. I can't seem to get any codes on the ODBII reader, so I can't quite tell what is going on. Anyone found a resolution and maybe a DIY fix?

mine has gone off a couple times over the last few weeks but comes back on. ive done quite a bit of driving since it first happened. I'm hoping when it warms up it goes away. also I'm going to check all the connections when the weather gets nice. i also picked up a code scanner and its showing not codes or issues so that didn't help.

if you get it to the dealer please let us know what the problem was.
 

·
Registered
Joined
·
14 Posts
I decided to hit the road to Key West from Southern Ohio in spite of the warning lights. About 50% of the time on the way down, the indicators went clear. I have an appointment at the dealership scheduled for the day after I get back. Everything "runs" fine except the cruise control (which is sorely missed.lol).

As soon as I'm able to get it diagnosed, I'll certainly post an update :)
 

·
Registered
Joined
·
469 Posts
Discussion Starter #9
so Monday it was in the mid 40's here in PA where i am and dry. i drove 100 miles to work in the morning and no light at all. i started van about 11 am and took a short 1 mile drive to lowes and it came on after about 100' into the drive after lowes it was off again and off for the whole rest of the day about 50-60 miles. That night it got cold and down to 20 degrees and we got 4" of snow the next morning (today) it was on from the moment i started it and had been on all day.. i just don't get it.... I'm thinking something is wet a a connector and its starting to dry but not totally dry and when it freezes it expanding and causes a disconnect somewhere. who knows just my theory! ill be looking forward to hearing about your dealer visit. Thanks.
 

·
Registered
Joined
·
2 Posts
ABS, ESC, Hill Assist

I'm getting the same error messages (17 gasser with about 25k miles). They seem to come and go over the past few days. I have a pretty long trip coming up at the end of the week and of course the dealership is booked until next week. I've been reading that in other vehicles this can be solved by replacing the brake light switch. I can't seem to get any codes on the ODBII reader, so I can't quite tell what is going on. Anyone found a resolution and maybe a DIY fix?
My abs,esc and brake lights just turned on. And a message on the screen. How did you fix this issue? 2017 ram promaster
 

·
Registered
Joined
·
14 Posts
My abs,esc and brake lights just turned on. And a message on the screen. How did you fix this issue? 2017 ram promaster
Ended up getting it into the dealership. It was a bad speed (ABS) sensor on the rear passenger wheel. Replaced under warranty. No problems since. Now at 67k miles.
 

·
Registered
Joined
·
2 Posts
Sounds weird. After driving more than 300miles down into warmer areas of Tennessee (coming from ky), I stopped for gas. And when I started it everything was normal again.
Its been almost a month now no problem
 

·
Registered
Joined
·
14 Posts
Sounds weird. After driving more than 300miles down into warmer areas of Tennessee (coming from ky), I stopped for gas. And when I started it everything was normal again.
Its been almost a month now no problem
Could be a fluke - or I guess it could have been some metal shavings in your wheel hub interfering with the speed sensor. And maybe stopping or reversing freed that up and solved the problem? I've also read of intermittent issues resulting in similar warning lights caused by the steering angle sensor needing adjustment (apparently can only be done with a specialized computer at a dealer [figures]). Looks like it ranges from a $200 - $400 fix. Hopefully it's a non-issue for you going forward!
 

·
Registered
Joined
·
14 Posts
Also - may or may not be relevant, but when I had the issue - the long trip I took was from Cincinnati down to Key West, FL in winter - and my indicators stayed on the whole time even as I went into warmer climates, so it may not be the same issue - or at least wasn't affected by the climate change.
 

·
Registered
Joined
·
2 Posts
I have a new ( less than 500 miles ) 2019 2500 136 gas high top. The hill assist light came on . The dealership said I needed an ABS Module. I have been waiting almost a month and the dealership being told that Dodge cannot supply it and it might not be until August. Any help here ? RB
 

·
Registered
Joined
·
3,316 Posts
I have a new ( less than 500 miles ) 2019 2500 136 gas high top. The hill assist light came on . The dealership said I needed an ABS Module. I have been waiting almost a month and the dealership being told that Dodge cannot supply it and it might not be until August. Any help here ? RB
@Ramberry contact @RamCares
 

·
Registered
Joined
·
57 Posts
I have a new ( less than 500 miles ) 2019 2500 136 gas high top. The hill assist light came on . The dealership said I needed an ABS Module. I have been waiting almost a month and the dealership being told that Dodge cannot supply it and it might not be until August. Any help here ? RB
Not sure if it's the same problem but I had the dash light up with Hill Assist/ABS/ESC problems and it was caused by the wires connecting the brake pad sensors shorting. Details here.
 
1 - 17 of 17 Posts
Top