Ram Promaster Forum banner

1 - 4 of 4 Posts

·
Registered
2014 RAM Promaster 2500
Joined
·
19 Posts
Discussion Starter #1
1. My idiot light "brake" is permanently illuminated red on the dash. Dealer wants $500+ to fix. Any alternatives? I am willing to let it stay lit and I will simply inspect the brake fluid level with my own eyes.

2. Both USB ports worked perfectly for 3 years but recently quit charging my iPhones. It is not the fuse.

3. My backup camera warning alarm constantly beeps when I am in reverse, instead of warning me when I approach a hazard.

Any help/advice is greatly appreciated.
 

·
Registered
Joined
·
552 Posts
1 - Why is it lit? That's the real issue. Is it the brake failure light, or the parking brake engaged light?

2 - Will they charge other USB devices? Apple has a way of intentionally preventing non Apple accessories from working. i.e. a third party USB cable won't charge but the OEM cable will.

3 - Have you made sure the sensors are clean and free of any dirt, obstructions, etc? Have you got a hitch, bike rack, etc. perhaps visible to the sensor. Are any of the wires to each sensor broken or disconnected?
 

·
Registered
2014 RAM Promaster 2500
Joined
·
19 Posts
Discussion Starter #3
1. I think it is the brake failure light since the mechanic said I needed to inspect fluid level visually. Also, I frequently get a message to service the brakes when I first start the van..

2. Good point, will try other devices. However, they did work for 3 years.

3. Sensors are clean and free of obstruction. I will inspect the wiring.

Thank you.
 

·
Registered
Joined
·
410 Posts
1. How many miles on your pads? What GapRunner said: what did dealer diagnose?

2. Charging cables are subject to failure over time. I'd think that's a more likely problem than the port.
 
1 - 4 of 4 Posts
Top