Lift Kit - Page 6 - Ram Promaster Forum
User Tag List

Reply
 
Thread Tools
post #51 of 53 Old 06-27-2019, 08:45 PM
mammothrunner
Member
 
Join Date: Nov 2018
Posts: 99
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Thanks: 6
Thanked 5 Times in 5 Posts
Mine shudders from 50-60 also with no mods just stock. There is a thread dedicated to this problem with a workaround but I can’t remember what it was. I’ll try to find the thread. Bugs me.
mammothrunner is offline  
Sponsored Links
Advertisement
 
post #52 of 53 Old 06-27-2019, 10:16 PM
Juve
Member
 
Juve's Avatar
 
Join Date: Jan 2019
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 0
Thanked 9 Times in 6 Posts
It could be something as simple as a missing wheel weight causing the shuddering. I'm assuming you checked all of the lug nuts.
Juve is offline  
post #53 of 53 Old 06-28-2019, 09:40 PM
Bruceiam
Junior Member
 
Join Date: Sep 2015
Location: Northern Illinois
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Can anyone shed a little light on this shudder issue? My diesel just started this between 45 and 60 MPH, worse as the load increases. I took the CV joints apart expecting to see some obvious ware but nothing.
Bruceiam is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome