Air Conditioning not working after winter - 2500 2018 - Ram Promaster Forum
User Tag List

Reply
 
Thread Tools
post #1 of 12 Old 04-15-2019, 12:01 AM Thread Starter
Carrot Eater
Member
 
Join Date: Sep 2018
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 4
Thanked 3 Times in 3 Posts
(Thread Starter)
Air Conditioning not working after winter - 2500 2018

I got my 2018 promaster 9/2018 and the AC worked. We didn't use the air conditioning much after 10/2018. Last week I tried using it and nothing. Anything I can check before I have to take it to the dealer?

2018 High Roof 159" Cargo Van, gas
Carrot Eater is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 04-15-2019, 01:19 AM
travelvanvan
Senior Member
 
travelvanvan's Avatar
 
Join Date: Feb 2018
Location: BC, Canada
Posts: 410
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Thanks: 272
Thanked 44 Times in 41 Posts
Garage
Quote:
Originally Posted by Carrot Eater View Post
I got my 2018 promaster 9/2018 and the AC worked. We didn't use the air conditioning much after 10/2018. Last week I tried using it and nothing. Anything I can check before I have to take it to the dealer?
Don't scare me like that! :-)

I picked up my PM in Sept 2018 too. And I didn't even use it once after the initial test at the dealer.

It could be that the refrigerant leaked out. Or in the case of my dad's Lexus, a relay failed; the one that engaged the clutch on the A/C compressor.

Let us know what happened.

Ordered Feb 2018, arrived Sept 2018. 159-inch WB regular length, high top, 3.6L gas, both driver's and passenger-side sliding doors. Planning to lightly camper-ize it for spontaneous and free-spirited travel!
travelvanvan is online now  
post #3 of 12 Old 04-15-2019, 08:12 AM
JohnnyRambles
Senior Member
 
Join Date: Mar 2017
Location: Rambling
Posts: 217
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 52 Post(s)
Thanks: 18
Thanked 64 Times in 45 Posts
Is the fan not working? Or is it just not blowing cold air? If the fan is working try cycling between heat and AC multiple times by turning the red/blue knob back and forth repeatedly. The Promasters are known for having an issue with the dampers sticking and it's happened several times on my van.

2015 159" Gas Promaster (RV Build in Progress)
JohnnyRambles is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 04-15-2019, 10:02 AM Thread Starter
Carrot Eater
Member
 
Join Date: Sep 2018
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 4
Thanked 3 Times in 3 Posts
(Thread Starter)
Quote:
Originally Posted by JohnnyRambles View Post
Is the fan not working? Or is it just not blowing cold air? If the fan is working try cycling between heat and AC multiple times by turning the red/blue knob back and forth repeatedly. The Promasters are known for having an issue with the dampers sticking and it's happened several times on my van.

The fan works but the outside temp was as cool as it gets. I'll try cycling the hot/cold. I pushed the AC button on it, turning it on & off. The green LED indicator cycles on/off with each press of the button.

2018 High Roof 159" Cargo Van, gas
Carrot Eater is offline  
post #5 of 12 Old 04-15-2019, 11:03 AM
HarryN
Member
 
HarryN's Avatar
 
Join Date: Jan 2019
Location: Pleasanton, CA
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Thanks: 26
Thanked 23 Times in 19 Posts
Garage
Usually you have to use an a/c at least some regularly - even in the winter - or the seals dry out and leak.

It might also be that it simply isn't warm enough yet for the A/C to allow it to turn on.

Those are speculation / guesses in case you cannot tell.

Some experience with auxiliary power
HarryN is offline  
post #6 of 12 Old 04-15-2019, 11:31 AM
KilWerBzz
Senior Member
 
KilWerBzz's Avatar
 
Join Date: May 2014
Location: Kyle, Texas
Posts: 1,028
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 194 Post(s)
Thanks: 3
Thanked 281 Times in 215 Posts
At operating temp and normal idle turn the a/c on can you hear the compressor start and or does your rpm edge up if so it is most likely your blend door. If you can safely touch the a/c lines in the engine compartment one should be cold the other hot when the a/c is running or use a laser to check.

2014 Ram Promaster 2500 HR 159" Diesel
Bow to RA and offer him Cadmium Telluride and he shall reward you.
KilWerBzz is offline  
post #7 of 12 Old 04-15-2019, 02:39 PM
KilWerBzz
Senior Member
 
KilWerBzz's Avatar
 
Join Date: May 2014
Location: Kyle, Texas
Posts: 1,028
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 194 Post(s)
Thanks: 3
Thanked 281 Times in 215 Posts
Quote:
Originally Posted by HarryN View Post
Usually you have to use an a/c at least some regularly - even in the winter - or the seals dry out and leak.
Any time you turn the defrost on the a/c will run this is to dehumidify the air and speed up the defogging, but it only helps if the blend door is working.

2014 Ram Promaster 2500 HR 159" Diesel
Bow to RA and offer him Cadmium Telluride and he shall reward you.
KilWerBzz is offline  
post #8 of 12 Old 04-15-2019, 03:14 PM
travelvanvan
Senior Member
 
travelvanvan's Avatar
 
Join Date: Feb 2018
Location: BC, Canada
Posts: 410
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Thanks: 272
Thanked 44 Times in 41 Posts
Garage
Quote:
Originally Posted by HarryN View Post
Usually you have to use an a/c at least some regularly - even in the winter - or the seals dry out and leak.
Understood and usually I'm good about it with our vehicles that are regularly driven. But my PM is (will be) used like an RV, in winters it just sits. I do charge the battery periodically. And I do remember starting the engine until it warmed once during the winter. Because I claim to know about this issue) I likely did turn on the AC during that time. But I can't fully remember.

Ordered Feb 2018, arrived Sept 2018. 159-inch WB regular length, high top, 3.6L gas, both driver's and passenger-side sliding doors. Planning to lightly camper-ize it for spontaneous and free-spirited travel!
travelvanvan is online now  
post #9 of 12 Old 04-29-2019, 02:51 PM
ShaunB
Senior Member
 
ShaunB's Avatar
 
Join Date: Nov 2014
Location: Uxbridge, ON, Canada
Posts: 343
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 78 Post(s)
Thanks: 177
Thanked 90 Times in 62 Posts
Garage
My AC is not working (2016 Diesel with 70,000km). I just learned from my dealer that the clutch in the compressor has a short and needs to be replaced. The part is over $1300 and labour etc is another $500+. Total bill of $2100 CDN incl. tax. I tried to source it aftermarket and there aren't any available. I'm frustrated that a vehicle just out of warranty (3 yr 60k in Canada) needs a new compressor. I just replaced the radiator a month ago!

Just venting.
Shaun

Sherpa is a 2016 3500 Ext. Diesel, Black - Our off grid cycling adventure vehicle. Also my Daily Driver. Follow my build and our adventures on https://www.instagram.com/sherpathevan/
ShaunB is offline  
post #10 of 12 Old 04-29-2019, 04:10 PM
MtBiker
Senior Member
 
MtBiker's Avatar
 
Join Date: May 2017
Location: California, Baja, Oregon
Posts: 181
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Thanks: 8
Thanked 46 Times in 37 Posts
Garage
Quote:
Originally Posted by ShaunB View Post
My AC is not working (2016 Diesel with 70,000km). I just learned from my dealer that the clutch in the compressor has a short and needs to be replaced. The part is over $1300 and labour etc is another $500+. Total bill of $2100 CDN incl. tax. I tried to source it aftermarket and there aren't any available. I'm frustrated that a vehicle just out of warranty (3 yr 60k in Canada) needs a new compressor. I just replaced the radiator a month ago!

Just venting.
Shaun
Find an air conditioner repair shop. You should be able to get just the clutch.

2017, High Top/159 WB, 2500 gas Promaster
MtBiker is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome