Any real mpg #'s yet? - Page 63 - Ram Promaster Forum
User Tag List

Reply
 
Thread Tools
post #621 of 625 Old 12-22-2016, 08:19 PM
Hecat1500
Junior Member
 
Join Date: Dec 2016
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
There is another post about the seat airbag and his solution was easy he ordered replacement parts and plugged them in to the harness all problems with function solved and under $300
Occupant detection switch
P/n 68237023aa
Seatbelt receptacle
P/n 5rm76jxwaa
Hecat1500 is offline  
Sponsored Links
Advertisement
 
post #622 of 625 Old 12-22-2016, 08:24 PM
RDinNHandAZ
Senior Member
 
RDinNHandAZ's Avatar
 
Join Date: Jul 2014
Location: Summer in Lakes Region of NH and Winter in the Sonoran Desert of AZ
Posts: 2,854
Thanks: 304
Thanked 532 Times in 431 Posts
Mentioned: 4 Post(s)
Tagged: 1 Thread(s)
Quoted: 600 Post(s)
Garage
Thanks for updating that post from a year and a half ago! We now know it can be done!

2015 136" HT Diesel Sandstone Metallic Born on 6/12/2015 Campervan build see: http://www.promasterforum.com/forum/...ad.php?t=37177
Have Leatherman, Will Travel
RDinNHandAZ is online now  
post #623 of 625 Old 01-24-2017, 10:51 PM
Rookerlw
Member
 
Join Date: Oct 2015
Location: Los Angeles County, California
Posts: 40
Thanks: 1
Thanked 12 Times in 8 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
I have a couple of mpg comparisons between Promasters run over the same 220 mile route over the last 2 years. Vans were unloaded and only carried about 100 lbs of odds and ends.

2015 rented a 136 1500 low roof gasser for several months. Drove it 4K miles. Went over the same 220 mile route between Los Angeles and Ventura multiple times. Averaged 21.3 mpg.

2016 received my 118 1500 low roof diesel and drove it 8K miles before repurchased by Chrysler due to emissions issues. Driving same 220 mile route multiple times averaged 28.7 mpg.

2017 rented a 159 2500 high roof gasser for several weeks. Drove it several times over the 220 mile Los Angeles-Ventura route. Averaged exactly 19.0 mpg.

Route went from Fullerton and the 91 fwy to the 605 fwy to the 5 fwy to the 126 fwy to the junction of the 126/101 fwy in Ventura returning by the same route in reverse. Always driven on Sunday so no traffic issues - clear sailing all the way. All mileage was calculated at the pump. Most of the time the mpg calculated by the vehicle was 0.5 to 0.75 higher than the mpg calculated at the pump at time of fill-up.

Lex
Rookerlw is offline  
The Following 2 Users Say Thank You to Rookerlw For This Useful Post:
Swoop (01-24-2017), windyyet (01-24-2017)
 
post #624 of 625 Old 01-30-2017, 06:00 PM
Jim_Escalante
Junior Member
 
Join Date: Jul 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2016 Promaster City

I purchased a City model in August of 2016. I tallied up my gas and mileage at the end of December of last year. Of the 3350 miles that I drove in the five months, only 600 were highway miles and it was on a single trip. Otherwise they were short trips in the city driving. My average is 20 miles per gallon. I carry photo equipment and some other items. Nothing heavy, but it is seldom empty. Hope this helps.
Jim
Jim_Escalante is offline  
post #625 of 625 Old 01-31-2017, 02:02 PM
Jim_Escalante
Junior Member
 
Join Date: Jul 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I purchased a 2016 Promaster City last August. Have only driven it about 3700 miles. Of those miles only 500 have been on the highway. The rest have been short trips in city driving. So far my average on total miles is 20 MPG. I transport camera equipment. It is seldom empty but hardly ever full of heavy items.

Jim
Jim_Escalante is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome