new PM diesel catalyst efficiency issue - Page 55 - Ram Promaster Forum
User Tag List

Reply
 
Thread Tools
post #541 of 541 Old 09-22-2016, 06:38 PM
2WheelCoder
Junior Member
 
2WheelCoder's Avatar
 
Join Date: May 2015
Location: Boulder, CO
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Quote:
Originally Posted by RDinNHandAZ View Post
Without the codes I am guessing and even with them I would be but it would be a better guess. Those symptoms have been posted up here and the eventual fix (IIRC) was a bunch of new wiring due to DEF corroding the wiring harness near the DEF injector. Bad/impure DEF could cause this or a contaminant in the tank. I am assuming the following: you have the most recent ECU update, the DEF has been topped up from a good source (some reports that “BlueDEF” has shown problems, but I doubt it), OR the DEF tank has been cleaned and refilled and the codes reset after a test run. I can’t recall these codes being fixed by replacing other parts although a few ‘14s got new DEF injector/pump. Certainly the catalytic converter would not be suspect from what you say, but without the codes??????
Thanks RDinNHandAZ for the suggestions. I asked the dealer for the codes and they said they'd send them over, but have not gotten back to me yet. I'll post here when they do.

For the third or fourth time they've called and told me it *might* be ready by end of day, and yet again I've gotten no response from them. Once I get those codes I'm going to take them to the dealer I purchased it from and see if they can help in the process or compensate me in some way.
2WheelCoder is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome