Waiting 3 Weeks on a new engine... and NOTHING. Anyone else? - Ram Promaster Forum
User Tag List

 
Thread Tools
post #1 of 6 Old 12-11-2016, 11:32 PM Thread Starter
tcup
Junior Member
 
Join Date: May 2016
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry Waiting 3 Weeks on a new engine... and NOTHING. Anyone else?

I posted earlier about my lovingly built out 2015 diesel 1500 PM needing a new ENGINE with 8800 miles on it. Well, they cleared me to get a replacement engine... 3 weeks ago as of this coming Tue.

Current word is my engine is in Detroit, in quarantine, getting quality checked, and there is no word on when it will be ready to ship or even when they will know when it will be available to ship.

Apparently they are checking a whole batch of engines?

But how many of those engines are bound for a vehicle stranded 11 hours from home, with the owner paying the price of 4 and counting weeks of lost use / lost opportunity for further buildout (Dec was my month to have work done on it!) / enjoyment / registration / insurance / van payments?

Anyone else? Any ideas for putting any pressure on Ram? This is getting absurd. And calling customer service line the best they will do is escalate you to a manager... who calls back within 2 days... and has no access to data about what is happening in Detroit or authority to compensate me in any way or make anything happen....
tcup is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 12-11-2016, 11:54 PM
Gator
Senior Member
 
Join Date: Mar 2015
Posts: 125
Thanks: 7
Thanked 28 Times in 24 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
FCA downed my jeep for a month waiting on a speedometer cluster, they did pay for a rental though. They also offered to make a monthly payment but since I did not finance, they declined. food for thought.

Last edited by Gator; 12-11-2016 at 11:56 PM.
Gator is offline  
post #3 of 6 Old 12-12-2016, 09:10 AM
MsNomer
Senior Member
 
MsNomer's Avatar
 
Join Date: Sep 2014
Location: Oklahoma, USA
Posts: 1,285
Thanks: 13
Thanked 254 Times in 198 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 297 Post(s)
My understanding is that FCA is not the culprit. Blame Volkswagon.
MsNomer is offline  
post #4 of 6 Old 12-14-2016, 11:40 PM
Kip-on-truckin
Senior Member
 
Kip-on-truckin's Avatar
 
Join Date: Jan 2014
Location: Akron, OH
Posts: 566
Thanks: 0
Thanked 37 Times in 32 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 185 Post(s)
Garage
You'll have to search here to find the older threads, but you do have the option of Lemon Lawing it. I would be throwing the phrase lemon law around when on the phone to FCA. Other than that, I got nothing.

A growing fleet, you may call me Admiral: 2014 3500 159"extended gas, and a 2014 2500 136" gas
Kip-on-truckin is offline  
post #5 of 6 Old 12-16-2016, 04:47 PM Thread Starter
tcup
Junior Member
 
Join Date: May 2016
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
An engine has finally been shipped! So stealthily that customer service had no idea it was going to be shipped! Well, customer service had no idea it HADN'T been shipped - they started calling the service center last week asking if the repair was done, and were "perplexed" to learn that NO, because YOU DIDN'T SHIP US AN ENGINE.

And of course upon installation turns out they didn't ship all the parts required for the engine, so repair is going to take an extra week while we wait on those additional parts.

Awesome!
tcup is offline  
post #6 of 6 Old 12-16-2016, 06:21 PM
RDinNHandAZ
Senior Member
 
RDinNHandAZ's Avatar
 
Join Date: Jul 2014
Location: Summer in Lakes Region of NH and Winter in the Sonoran Desert of AZ
Posts: 2,710
Thanks: 282
Thanked 487 Times in 396 Posts
Mentioned: 4 Post(s)
Tagged: 1 Thread(s)
Quoted: 571 Post(s)
Garage
Can you find out what failed in your other engine? 8000 miles use so it had to be something done or not done during assembly or a bad component. Did they sent a long block (head installed?). What were the symptoms of the failure?

2015 136" HT Diesel Sandstone Metallic Born on 6/12/2015 Campervan build see: http://www.promasterforum.com/forum/...ad.php?t=37177
Have Leatherman, Will Travel
RDinNHandAZ is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome